Skip to main content
← All vulnerabilities
CVE-2025-1828

Perl's Crypt::Random module after 1.05 and before 1.56 may use rand() function for cryptographic functions

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.56
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Crypt::Random Perl package 1.05 through 1.55 may use rand() function, which is not cryptographically strong, for cryptographic functions. If the Provider is not specified and /dev/urandom or an Entropy Gathering Daemon (egd) service is not available Crypt::Random will default to use the insecure Crypt::Random::rand provider. In particular, Windows versions of perl will encounter this issue by default.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Crypt-Random

    From 1.05 · fixed in 1.56

References 3

perldoc.perl.org

GitHub · perl-Crypt-OpenPGP/Crypt-Random