Skip to main content
← All vulnerabilities
CVE-2025-15346GHSA-VJ87-JJ27-4H9CPYSEC-2026-575

wolfSSL Python library `CERT_REQUIRED` mode fails to enforce client certificate requirement

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.8.4.post0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced.  Because the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided.  This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake.  The issue affects versions up to and including 5.8.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • wolfssl

    From 5.3.0 · through 5.8.2

  • wolfsslPyPI

    fixed in 5.8.4.post0

References 3

GitHub · wolfSSL/wolfssl-py