Skip to main content
← All vulnerabilities
CVE-2025-14691GHSA-774Q-R975-VQWPPYSEC-2025-134

Mayan EDMS authentication cross site scripting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.10.2, 4.9.7, 4.8.10, 4.7.8, 4.6.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. You should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mayan EDMS

    4.10.0, 4.10.1

  • mayan-edmsPyPI

    From 4.10.0 · fixed in 4.10.2

  • mayan-edmsPyPI

    From 4.9.0 · fixed in 4.9.7

  • mayan-edmsPyPI

    From 4.8.0 · fixed in 4.8.10

  • mayan-edmsPyPI

    From 4.7.0 · fixed in 4.7.8

  • mayan-edmsPyPI

    fixed in 4.6.12

  • mayan-edmsPyPI

    fixed in 4.10.2

References 6

vuldb.com

GitHub · ionutluca888/Mayan-EDMS-XSS-POC

docs.mayan-edms.com