CVE-2025-14435GHSA-MX8M-V8QM-XWR8GO-2026-4326
Application-Level DoS via infinite re-render loop in user profile handling
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 10.11.9, 11.1.2, 11.0.7, 10.11.9+incompatible, 11.0.7+incompatible, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Mattermost versions 10.11.x <= 10.11.8, 11.1.x <= 11.1.1, 11.0.x <= 11.0.6 fail to prevent infinite re-renders on API errors which allows authenticated users to cause application-level DoS via triggering unbounded component re-render loops.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Mattermost Mattermost
From 10.11.0 · through 10.11.8; From 11.1.0 · through 11.1.1; From 11.0.0 · through 11.0.6
- github.com/mattermost/mattermost-serverGo
From 10.11.0 · fixed in 10.11.9
- github.com/mattermost/mattermost-serverGo
From 11.1.0 · fixed in 11.1.2
- github.com/mattermost/mattermost-serverGo
From 11.0.0 · fixed in 11.0.7
- github.com/mattermost/mattermost-serverGo
From 10.11.0+incompatible · fixed in 10.11.9+incompatible; From 11.0.1+incompatible · fixed in 11.0.7+incompatible; From 11.1.0+incompatible · fixed in 11.1.2+incompatible