Skip to main content
← All vulnerabilities
CVE-2025-13984DRUPAL-CONTRIB-2025-122

Next.js - Critical - Access bypass - SA-CONTRIB-2025-122

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.6.4, 2.0.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Permissive Cross-domain Security Policy with Untrusted Domains vulnerability in Drupal Next.Js allows Cross-Site Scripting (XSS).This issue affects Next.Js: from 0.0.0 before 1.6.4, from 2.0.0 before 2.0.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Drupal Next.js

    From 0.0.0 · fixed in 1.6.4; From 2.0.0 · fixed in 2.0.1

  • drupal/nextPackagist

    fixed in 1.6.4; From 2.0.0 · fixed in 2.0.1

References 1

drupal.org