Skip to main content
← All vulnerabilities
CVE-2025-13928

Incorrect Authorization in GitLab

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 18.6.4, 18.7.2, 18.8.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.7 before 18.6.4, 18.7 before 18.7.2, and 18.8 before 18.8.2 that could have allowed an unauthenticated user to cause a denial of service condition by exploiting incorrect authorization validation in API endpoints.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 17.7 · fixed in 18.6.4; From 18.7 · fixed in 18.7.2; From 18.8 · fixed in 18.8.2

References 3

gitlab.com

hackerone.com

about.gitlab.com