Skip to main content
← All vulnerabilities
CVE-2025-12943

Improper certificate validation in firmware update logic in NETGEAR RAX30 and RAXE300

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.10.95, 1.0.9.82
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Improper certificate validation in firmware update logic in NETGEAR RAX30 (Nighthawk AX5 5-Stream AX2400 WiFi 6 Router) and RAXE300 (Nighthawk AXE7800 Tri-Band WiFi 6E Router) allows attackers with the ability to intercept and tamper traffic destined to the device to execute arbitrary commands on the device. Devices with automatic updates enabled may already have this patch applied. If not, please check the firmware version and update to the latest. Fixed in: RAX30 firmware 1.0.14.108 or later. RAXE300 firmware 1.0.9.82 or later

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • NETGEAR RAX30

    fixed in 1.0.10.95

  • NETGEAR RAXE300

    fixed in 1.0.9.82

References 3

netgear.com

kb.netgear.com