Remote Code Execution in Looker via Teradata JDBC Driver
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 24.12.108, 24.18.200, 25.0.78, 25.6.65, 25.8.47, and 2 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
A Looker user with a Developer role could cause Looker to execute a malicious command, due to insecure processing of Teradata driver parameters. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : • 24.12.108+ • 24.18.200+ • 25.0.78+ • 25.6.65+ • 25.8.47+ • 25.12.10+ • 25.14+
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Google Cloud Looker
fixed in 24.12.108; fixed in 24.18.200; fixed in 25.0.78; fixed in 25.6.65; fixed in 25.8.47; fixed in 25.12.10; fixed in 25.14
- Google Cloud Looker
fixed in 24.12.108; fixed in 24.18.200; fixed in 25.0.78; fixed in 25.6.65; fixed in 25.8.47; fixed in 25.12.10; fixed in 25.14