Skip to main content
← All vulnerabilities
CVE-2025-12741

Arbitrary File Write in Denodo dialect of Looker allows Remote Code Execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 24.12.108, 24.18.200, 25.0.78, 25.6.65, 25.8.47, and 2 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

A Looker user with Developer role could create a database connection using Denodo driver and, by manipulating LookML, cause Looker to execute a malicious command. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : • 24.12.108+ • 24.18.200+ • 25.0.78+ • 25.6.65+ • 25.8.47+ • 25.12.10+ • 25.14+

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Google Cloud Looker

    fixed in 24.12.108; fixed in 24.18.200; fixed in 25.0.78; fixed in 25.6.65; fixed in 25.8.47; fixed in 25.12.10; fixed in 25.14

  • Google Cloud Looker

    fixed in 24.12.108; fixed in 24.18.200; fixed in 25.0.78; fixed in 25.6.65; fixed in 25.8.47; fixed in 25.12.10; fixed in 25.14

References 1

cloud.google.com