Skip to main content
← All vulnerabilities
CVE-2025-12739

Cross-Site Scripting (XSS) in Looker's Extension Loader leading to Admin Account Compromise

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 24.18.201, 25.0.79, 25.6.66, 25.12.7, 25.16.0, and 2 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

An attacker with viewer permissions in Looker could craft a malicious URL that, when opened by a Looker admin, would execute an attacker-supplied script. Exploitation required at least one Looker extension installed on the instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.18.201+ • 25.0.79+ • 25.6.66+ • 25.12.7+ • 25.16.0+ • 25.18.0+ • 25.20.0+

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Google Cloud Looker

    fixed in 24.18.201; fixed in 25.0.79; fixed in 25.6.66; fixed in 25.12.7; fixed in 25.16.0; fixed in 25.18.0; fixed in 25.20.0

  • Google Cloud Looker

    fixed in 24.18.201; fixed in 25.0.79; fixed in 25.6.66; fixed in 25.12.7; fixed in 25.16.0; fixed in 25.18.0; fixed in 25.20.0

References 1

cloud.google.com