Skip to main content
← All vulnerabilities
CVE-2025-1252

Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.5.0, 7.3.0.7, 6.1.2.23, 6.0.1.42
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Heap-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Variables and Tags. This issue affects Connext Professional: from 7.4.0 before 7.5.0, from 7.0.0 before 7.3.0.7, from 6.1.0 before 6.1.2.23, from 6.0.0 before 6.0.1.42, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 4.4d before 5.1.*.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • connext_professional

    From 7.4.0 · fixed in 7.5.0; From 7.0.0 · fixed in 7.3.0.7; From 6.1.0 · fixed in 6.1.2.23; From 6.0.0 · fixed in 6.0.1.42; From 5.3.0; From 5.2.0; From 4.4d

References 1

rti.com