Skip to main content
← All vulnerabilities
CVE-2025-12472

Remote Code Execution in Looker due to Improperly Validated Directory Deletion

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 24.12.103, 24.18.195, 25.0.72, 25.6.60, 25.8.42, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

An attacker with a Looker Developer role could manipulate a LookML project to exploit a race condition during Git directory deletion, leading to arbitrary command execution on the Looker instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : • 24.12.103+ • 24.18.195+ • 25.0.72+ • 25.6.60+ • 25.8.42+ • 25.10.22+

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Google Cloud Looker

    fixed in 24.12.103; fixed in 24.18.195; fixed in 25.0.72; fixed in 25.6.60; fixed in 25.8.42; fixed in 25.10.22

  • Google Cloud Looker

    fixed in 24.12.103; fixed in 24.18.195; fixed in 25.0.72; fixed in 25.6.60; fixed in 25.8.42; fixed in 25.10.22

References 1

cloud.google.com