Skip to main content
← All vulnerabilities
CVE-2025-12414

Looker account compromise via punycode homograph attack

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 24.12.100, 24.18.193, 25.0.69, 25.6.57, 25.8.39, and 2 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

An attacker could take over a Looker account in a Looker instance configured with OIDC authentication, due to email address string normalization.Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : • 24.12.100+ • 24.18.193+ • 25.0.69+ • 25.6.57+ • 25.8.39+ • 25.10.22+ • 25.12.0+

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Google Cloud Looker

    fixed in 24.12.100; fixed in 24.18.193; fixed in 25.0.69; fixed in 25.6.57; fixed in 25.8.39; fixed in 25.10.22; fixed in 25.12.0

  • Google Cloud Looker

    fixed in 24.12.100; fixed in 24.18.193; fixed in 25.0.69; fixed in 25.6.57; fixed in 25.8.39; fixed in 25.10.22; fixed in 25.12.0

References 1

cloud.google.com